EU Data Center Performance Degradation - Unable to Log in/New User Interface
Incident Report for Shiftboard
Postmortem

Our London data center was updated with software updates to the Responsive Web user interface around 11.30 pm London time Monday April 5th. The update failed to apply correctly on one of two servers in London, resulting in login failures for a subset of our European customers who default to that Responsive Web user interface at login. Because this issue only impacted a very small number of European customers it was not trapped by application monitoring or QA until the first support request came in at 11:46 am London time Tuesday April 6th. The issue was addressed around 4pm London time Tuesday. Shiftboard will be increasing AWS server resources in the London data center this month as a mitigation against the risk of future software update failures.

Posted Apr 06, 2021 - 14:18 PDT

Resolved
Our European sites experienced log in troubles accessing our platform through our new user interface after a code release took place overnight and the issue has been resolved at 7:37am Pacific Time.
Posted Apr 06, 2021 - 07:53 PDT
This incident affected: Mobile Site.