ScheduleFlex - Users unable to Login from our Homepage
Incident Report for Shiftboard
Resolved
This incident has been resolved.
Posted Apr 29, 2022 - 21:11 PDT
Monitoring
Starting at approximately 7am PT Friday, Shiftboard.com was a target of a large scale DDoS attack. This attack launched millions of requests at our website with the goal of bringing our services offline.

ScheduleFlex services were resilient to the attack and we were able to keep systems operational. There were degradations in performance as the waves of attacks came at us. Users would have experienced periodic slow load times and/or intermittent failed requests.

At approximately 7:30pm PT Friday, we were able to mitigate the attack and block all malicious requests. All services have resumed at normal speed.

At no point during the attack was there a breach of our services, security or data integrity. No customer data was ever at risk. This was an external attack that stayed external to our systems.

We will continue monitoring for the remainder of the night to ensure everything remains sound.
Posted Apr 29, 2022 - 20:40 PDT
Update
We are diligently investigating the issues impacting ScheduleFlex. At this time, they are impacting access more frequently and for longer periods of time causing slowness and timeout errors

We will provide an update on this issue when we know more information.
Posted Apr 29, 2022 - 17:48 PDT
Update
We are continuing to investigate the root cause of the issues impacting ScheduleFlex. If you see 'undergoing temporary maintenance', you can still click on the login link or use the direct URL to access your site.

We continue experiencing intermittent slowness and timeout errors. We will provide an update on this issue when we know more information.
Posted Apr 29, 2022 - 13:34 PDT
Update
We are continuing to investigate the root cause of the issues impacting ScheduleFlex. We are experiencing intermittent slowness and timeout errors. We will continue providing updates as we learn more.
Posted Apr 29, 2022 - 12:05 PDT
Update
We are continuing to investigate the root cause of the maintenance issues on our homepage. This is now impacting the ScheduleFlex platform causing slowness and timeout errors. We will provide updates as we learn more.
Posted Apr 29, 2022 - 10:17 PDT
Investigating
We are currently experiencing a Temporary Maintenance error message only when users attempt to log in from our Homepage (shiftboard.com/log-in) and we are currently investigating the issue. There is no impact for users that log in to Organization specific login pages and apologize for any inconvenience.

We will provide updates as we know more.
Posted Apr 29, 2022 - 08:31 PDT
This incident affected: Desktop Site, API, Mobile Site, PDF Generation, Messaging Services, IVR, Account Documents, and Registration Page.