PSMS Broadcast Messages
Incident Report for Shiftboard
Resolved
We worked with Twilio to successfully verify all toll-free Premium SMS phone numbers to meet carrier standards.
Posted Jul 29, 2022 - 07:11 PDT
Update
Some customers may be experiencing issues with Premium SMS broadcast message delivery given hardened requirements for source number verification applied by mobile text message carriers. So while broadcast messages may be sent by both email and SMS, in some cases the message may not be received by all workers as an SMS. Email receipt of broadcast messages is unaffected but some SMS messages may not be delivered by certain carriers. We are continuing to work with Twilio to fully restore broadcast messages via text.
Posted Jul 28, 2022 - 16:44 PDT
Identified
Some customers may be experiencing issues with Premium SMS broadcast message delivery given hardened requirements for source number verification applied by mobile text message carriers. So while broadcast messages may be sent by both email and SMS, in some cases the message may not be received by all workers as an SMS. Email receipt of broadcast messages is unaffected but some SMS messages may not be delivered by certain carriers. We are working to address the issue with Twilio and will post updates as they come available. All other ScheduleFlex features remain available without issue.
Posted Jul 27, 2022 - 16:54 PDT
This incident affected: Messaging Services.